cPanel & WHM Version 102 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

Provide Node.js v12 or later

Michigan Tech IT shared this idea 7 months ago
Completed

As a System Administrator, I would like to be able to provide Node.js v12 or later, so that we can provide our customers with a version that is not end-of-life, is more secure, and compatible with newer Node.js apps.


See https://forums.cpanel.net/threads/cpanel-32218-any-way-to-update-node-js-version.675821/ for more discussion of this.

Best Answer
photo

EasyApache now supports NodeJS 16!

Replies (5)

photo
5

Or the next LTS version of nodejs which is 14

photo
5

NodeJS is used for not only JS apps but for the package manager too which works alongside Laravel the most used PHP framework! This has been an ongoing issue with cPanel for the last 2 years across forums and StackOverflow!

photo
3

This is a common use case for our clients.

photo
4

Current LTS is 16.13. It would be great to get an update to this version.

Releases | Node.js (nodejs.org)

photo
5

And cPanel should track the LTS version for the future

photo
1

cPanel has released NodeJS 16 as part of EasyApache!

photo
6

Wow, it took me some time to find this! I was ready to post a new topic.

Right now we have the possibility to serve NodeJs apps that no one can use, because no one uses version 10 any more.

We really need either a cPanel backed solution or a way to upgrade it manually.

photo
1

EasyApache now supports NodeJS 16!

Replies have been locked on this page!