cPanel & WHM Version 94 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

Add EA3 PHP "Silence Deprecated Patch" to EA4 PHP

cPanelChrisD shared this idea 4 years ago
Open Discussion

As a server administrator, I would like to see the EA3 PHP "Silence Deprecated Patch" option added to EA4 so that migration from EA3 can be as seamless as possible.

After migrating from EA3 to EA4, some PHP code can begin emitting errors that were previously not reported by EA3 PHP when the "Silence Deprecated Patch" was enabled.


These errors are generated by deprecated code when the E_DEPRECATED and E_USER_DEPRECATED error_reporting flags are enabled, which are part of E_ALL by default. The EA3 patch removed these error reporting flags from E_ALL, but they could be individually enabled if needed.

Comments (1)

photo
1

This would be great for an easier upgrade!.

Leave a Comment
 
Attach a file