cPanel & WHM Version 94 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

Add Horde (Turba) globally shared address book management options in Tweak Settings

Kenny Say shared this idea 6 years ago
Needs Feedback

Up until a recent upgrade of Horde globally shared address books could be disabled by setting 'use_shares' to false in turba/config/sources.php. However this no longer works. It would be a good idea if there were an option to disable globally shared address books in Tweak Settings.

Best Answer
photo

It looks like you've already posted this to Horde's bug tracker (which is the appropriate way to handle the issue of its behavior changing). However, have you tried the recommended fix from the post above your own post on the bug site?


https://bugs.horde.org/ticket/13609


"Setting use_shares to false *completely* disables shares in Turba. So,

no user created address books at all. For what you want, you probably

want to look at the shares section of the main horde config.

Especially the [share][no_sharing] and [share][share_world] settings."


Using those options respectively performs the actions mentioned. Setting "no_sharing" to true in config/conf.php disables sharing, for instance.


As you say, this is potentially a change in logic. We attempt to perform minimalistic changes to Horde to get it to function in a shared environment, therefore the best way to handle any issues like this is if you disagree with the change in logic is exactly as you've done with posting them upstream to Horde's development.


Until then, perhaps the advised alternate (and potentially better/intended according to the bugs post?) is your best bet.

Comments (2)

photo
1

It looks like you've already posted this to Horde's bug tracker (which is the appropriate way to handle the issue of its behavior changing). However, have you tried the recommended fix from the post above your own post on the bug site?


https://bugs.horde.org/ticket/13609


"Setting use_shares to false *completely* disables shares in Turba. So,

no user created address books at all. For what you want, you probably

want to look at the shares section of the main horde config.

Especially the [share][no_sharing] and [share][share_world] settings."


Using those options respectively performs the actions mentioned. Setting "no_sharing" to true in config/conf.php disables sharing, for instance.


As you say, this is potentially a change in logic. We attempt to perform minimalistic changes to Horde to get it to function in a shared environment, therefore the best way to handle any issues like this is if you disagree with the change in logic is exactly as you've done with posting them upstream to Horde's development.


Until then, perhaps the advised alternate (and potentially better/intended according to the bugs post?) is your best bet.

photo
1

Shared address books can still be disabled, but the path to the necessary file is /usr/local/cpanel/base/horde/turba/config/backends.php now.

Leave a Comment
 
Attach a file