Add mod_evasive in Apache 2.4

phoenixweb shared this idea 2 years ago
Pre-Release

ISSUE: mod_evasive is not supported by Easy Apache for Apache 2.4

WHY: compatibility issue due to change in some vars of Apache from 2.2 to 2.4

FURTHER RELEASE: the original creator of this module probably won't will keep this updated.

HOW TO?

The issue is about incorrect name of the apache system vars.

Make it work is just a matter of renaming 2 or 3 keywords in the module.

This is as simple as many people decided to create a fork for Apache 2.4 by their own.

WHAT cPANEL CAN DO?

Normally cPanel doen't build fix/forked modules and don't take the ownership of these kind of project.

But cPanel can start to use one of the many forked modules already available.

For example: https://github.com/shivaas/mod_evasive

Please add this mod_evasive compatibile fork to the next Easy Apache!

It was a big shield for many issues.

Thanks,

Massimiliano Cuttini

Comments (1)

photo
1

This package is now available in the EasyApache 4 Experimental Repo:

  1. [root@edge66 ~]# yum list ea-apache24-mod_evasive
  2. Available Packages
  3. ea-apache24-mod_evasive.x86_64 1.10.1-1.1.21.cpanel EA4-experimental
  4. [root@edge64 ~]#