cPanel & WHM Version 98 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

Add PDO PostgreSQL (PDO_PGSQL) to EasyApache

Oldiesmann shared this idea 7 years ago
Open Discussion

EasyApache should support configuring PHP with the PostgreSQL driver for PDO as well. It makes no sense to support native PostgreSQL functions but not PDO PostgreSQL functions, especially when you already have MySQL support for PDO.

Best Answer
photo

This isn't planned at all right now, but if there is enough community support we would definitely consider it for EasyApache 4. Thanks, Brett, for your feedback here, too!

Replies (4)

photo
1

Yes, please. I got it running by download (not install) with PECL and then configuring with --with-pdo-pgsql=shared switch, making and making install.

photo
1

This isn't planned at all right now, but if there is enough community support we would definitely consider it for EasyApache 4. Thanks, Brett, for your feedback here, too!

photo
1

You can install it from your WHM also. Please follow the steps mentioned below:


WHM: Main >> Software >> Module Installers >> PHP Pecl >> PDO_PGSQL

photo
1

This gets PDO and works, but to get PSQl itself you have to install outside WHM since WHM only handles a earlier version (9.2) and current version is 9.5 which has many improvements, security updates and fixes. If you install 9.5 via yum and then try and use WHM to manage it nothing works.

Leave a Comment
 
Attach a file