Add support for mod_pagespeed to easyapache4

wouta shared this idea 1 year ago
Pre-Release

I want to insert the reqeust to add support of mod_pagespeed to easy apache 4.

Comments (9)

photo
3

I've built these RPMs and placed them in our ea4-experimental repository. You can install them by running the following:

  1. yum install ea4-experimental
  2. yum install ea-apache24-mod_pagespeed

Please let us know how it works!

You can read more about the experimental repo here:

https://documentation.cpanel.net/display/EA4/The+Experimental+Repository

photo
1

Firstly, great move. We already have mod_pagespeed installed from the Github repo. Is there any difference from this to your RPM's?

photo
1

Where can I find the mod_pagespeed configuration file? I have installed it, it was enabled in EA4 but I couldn't see that it took effect like combining CSS files, hence I wanted to verify the config is supposed to do this.

photo
1

ea-apache24-mod_ruid2 was conflicting so i have removed it and reinstalled mod_pagespeed, and now its working fine.

Thanks

photo
1

This is great, thank you Jacob.

Neil, both installs are similar. We ended up uninstalling the other github one and removing all the files manually before installing this EA4 version of pagespeed.

Martin, the config is at: /etc/apache2/conf.modules.d/456_pagespeed.conf. Take note that the location blocks in this conf are in Apache 2.2 mode, so off the bat you should change to Apache 2.4 style (ie Require all denied instead of Order). You need to make a handler for pagespeed_admin:

<Location "/pagespeed_admin">

Require all denied

Require local

Require ip 123.123.123.123

SetHandler pagespeed_admin

</Location>

And to access that pagespeed_admin, add a line in .htaccess after the directive(s) for .well-known/acme-challenge: RewriteCond %{REQUEST_URI} !^/pagespeed_admin[/0-9a-zA-Z_-]*$

Also, if there are permission issues in apache error log, make sure the cache is owned by Apache: chown -R nobody:nobody /var/mod_pagespeed/

There are some hiccups with serf too hitting port 80 (while using frontend such as cloudflare) however im not sure how to solve those yet (ModPagespeedFetchHttps enable doesnt do anything for it). If anyone has thoughts i would appreciate it.

photo
1

Any plans when is this gonna be implemented without using the experimental repository? Thanks!

photo
1

Nothing defined yet, but if that comes up we'll definitely communicate that here!

photo
photo
1

This is awesome. Thank you!!!

photo
1

Is anyone else able to set the timeout for rewrites in logs to a higher threshold? In pagespeed conf: "ModPagespeedSlowFileLatencyUs 100000" + restart httpd/php-fpm should increase it to 100ms before it complains, but it seems to do nothing (although /pagespeed_admin reports it is indeed set correct). Is this a hiccup you are seeing as well?