cPanel & WHM Version 94 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

Allow the use of Let's Encrypt for cPanel services

Monarobase shared this idea 21 months ago
Open Discussion

As a web hosting provider, we would like to have the option to use Let's Encrypt for cPanel services instead of cPanel's certificates so that users with older versions of Mac OS Mail can receive their e-mail.

Sectigo/Comodo certificiates are not compatible with older versions of Mac OS Mail and using Let's Encrypt resolves this issue.

Leave a Comment
 
Attach a file