cPanel & WHM Version 92 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!
This object is in archive! 

Allow using multiple PHP versions in EasyApache 3

postcd shared this idea 4 years ago
Not Planned

Hello,


there are similar feature requests like:

https://features.cpanel.net/topic/allow-to-install-multiple-php-5x-versions (Marked Complete, but for EA 4, not EA 3)

https://features.cpanel.net/topic/allow-to-install-php-5-3-in-easy-apache-4 (but for EA 4, not EA 3)


But please allow multiple PHP versions for Easy Apache 3 (EA 3) server. Currently i am on outdated 5.3 and wish to stay on that + offer 5.4 and 5.5 + to the cPanel clients.


There are third party apps like Cloudlinux and https://www.nixtree.com/ntphp.php which should support multi PHP. But i prefer cPanel made solution.


Either please allow 5.3 in EA 4 or allow multiple PHP in EA 3? Thank You

Comments (1)

photo
1

Hi there! Thanks so much for your interest in improving cPanel & WHM. At this time we are planning to move away from EasyApache 3 in favor of EasyApache 4, and are dropping support for CentOS 5, and all 32-bit systems on any version higher than v56, which you can read about on the blog:


https://blog.cpanel.com/end-of-life-for-centos5/


At this time cPanel isn't planning to provide hardened versions of outdated/End-of-life PHP versions like CloudLinux provides. I recommend upgrading your application to work on a supported version of PHP, and migrating away from CentOS 5 as soon as possible.

Replies have been locked on this page!