cPanel & WHM Version 98 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

EasyApache Ruby update - Ruby 2.5 and 2.6 are required by some Ruby and Ruby on Rails Apps

ylluminate shared this idea 22 months ago
Open Discussion

As a System Administrator, I would like Ruby/Ruby on Rails updated in EasyApache because Ruby 2.5 and 2.6 are required for some deployment situations.


==========

I'm currently running into problems with Ruby and Ruby on Rails apps that require Ruby 2.5 and even 2.6.5 in some cases. EasyApache needs to integrate a method ASAP to incorporate handling newer versions of Ruby such as how RVM or other tools allow it. RVM, for example, could be useful since it can handle Ruby versions and isolated Bundler configurations. This is extremely important and having EasyApache bound down to Ruby 2.4.x is making deployment impossible in many situations that I'm involved with.


Also, an updated Phusion Passenger would also be useful in this same situation in facilitating more flexible scenarios such as this.

Leave a Comment
 
Attach a file