cPanel & WHM Version 98 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

Exim: Stop hardcoding av_scanner

Boris Senker shared this idea 5 years ago
Completed

It's not easy to implement a remote av_scanner with this value being hardcoded in /usr/local/cpanel/Cpanel/Exim/Config.pm. One of the possible solutions would be to wrap this line in /usr/local/cpanel/Cpanel/Exim/Config.pm into an IF clause:


if (! -e "/etc/clamddisable" ) {

$CF{'CONFIG'} .= "\nav_scanner = clamd:/var/clamd\n";

}


This way an alternate av_scanner line would be possible to be put into exim.conf.local, no need to uninstall cpanel-clamav, and buildeximconf builds Exim nicely and properly without removing the malware ACL.

Replies (4)

photo
1

Hi Boris,


You should be able to overwrite this value by changing it in Advanced Exim Config editor in WHM.

photo
1

No you can't. If you try putting something like

clamd:$SOMEIPADDRESS $CLAMAVPORT

you'll get error like

Error message from syntax check:

2015-10-29 11:02:35 Exim configuration error in line 94 of /etc/exim.conf.buildtest.work.MftLTMAwGnyL0qZj:

"av_scanner" option set for the second time


Ticket for this is in, details are in it.

photo
1

Hi Boris,


This seems like a bug to me. Sorry for the inconvenience.


I have filed case CPANEL-2224: av_scanner cannot be configured in the Advanced Exim Editor to have this addressed.

photo
1

Also, can you make it so if I delete the av_scanner line, it stays deleted.


I'm not using clamav to scan mail so I don't have the daemon running all the time, but I still have clamav install for other scanning.


Every time I update cPanel, the av_scanner line comes back... at least until recently, now it comes back immediately. Quite annoying. I have the scanning options disabled in the Exim Basic Editor so it shouldn't force it back in if it's not being used and without the daemon running I just get repeated messages about it missing in the logs.

Replies have been locked on this page!