cPanel & WHM Version 94 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

Fix munin mysql_* plugin

burn1024 shared this idea 5 years ago
Open Discussion

As described here https://forums.cpanel.net/threads/munin-mysql2-plugin-isnt-working.464321, please make Munin mysql_ plugin work out of box. That requires:

1) Updating actual plugin file so it does work with mysql 5.5/5.6

2) Shipping required perl modules (Cache::Cache, IPC::SharedCache) as a dependency for Munin.

Comments (1)

photo
1

AFAIK Cache:Cache already ships as cpanel-perl-Cache-Cache, while IPC:ShareLite can be installed with:

/usr/local/cpanel/3rdparty/perl/530/bin/perl /usr/local/cpanel/bin/cpanm IPC::ShareLite
however neither the shipped mysql_ plugin, nor the latest from github work.

Since the current mysql plugins now shows a "Note that this is a old plugin which is no longer installed by default. It is retained for compatability with old installations." warning, it would be nice if the newer plugin would be implemented.

Leave a Comment
 
Attach a file