cPanel & WHM Version 98 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

friendlier mod_evasive support for WHM

feanor shared this idea 3 years ago
Open Discussion

Hi.

As a system administrator & shared hosting provider, it would be wonderful if mod_evasive were more readily configurable for admins (via the GUI)- it would almost certainly lead to this tech being deployed at an increasing clip and less support requests for everyone, for any myriad of reasons.

Of course, additional auto-defensive security is great! And, this is an easy integration. But first the feature needs to be arranged so that all of the prerequisites are there to avoid chaos.

Ideally you could sort out a separate "Apache Security Center" which sets aside mod_security, mod_evasive, and let that section evolve. For the evasive end, options to tweak the whitelist, blocking period, reactive command(s), notifications.. well, at least a handful of items would need to be immediately configurable. And, verbosely explained, of course.

Let me know what you think.

Thanks as always, good people.

Leave a Comment
 
Attach a file