cPanel & WHM Version 98 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

ModSecurity v3 Support

cPanelMichael shared this idea 3 years ago
Open Discussion

As a web hosting provider and system administrator, I would like to see support for ModSecurity version 3 (libmodsecurity) offered in cPanel & WHM through the ModSecurity-apache connector so that I can take advantage of the improved performance and added features noted at https://github.com/SpiderLabs/ModSecurity/blob/v3/master/README.md.

[Submitted on behalf of a user on the cPanel Forums - https://forums.cpanel.net/threads/mod_security-dbm-question-in-2018.621635/#post-2581905];

Replies (2)

photo
3

I would also like to see this implemented.

Modsec 2.x development looks dead, and functions like SecGeoLookupDb only has support for legacy outdated geoip databases which is discontinued since 2 jan 2019.

photo
2

ModSecurity 3 is available in the EA4 experimental repository. We will move it from the experimental repository when ModSecurity does a stable release.

Leave a Comment
 
Attach a file