cPanel & WHM Version 92 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

MPM-ITK Apache 2.4 support in EasyApache

Rachid Achellal shared this idea 6 years ago
Completed

please add mpm-itk support for apache 2.4. The lastest version of mpm-itk is compatible with 2.4. http://mpm-itk.sesse.net/.

Best Answer
photo

Adding MPM ITK support for Apache 2.4 is a wonderful feature request. I also think it'd be a great addition to EasyApache. Our implementation of ITK support for Apache 2.2 is nearing completion and we are actively discussing adding 2.4 support.

Comments (24)

photo
1

Support for MPM ITK in Apache 2.2 is planned for EasyApache version 3.26; however, support for MPM ITK in the newer Apache 2.4 may depend on increased community interest via this feature request. If you want to see this feature request implemented, that is, specific support of ITK in Apache 2.4 and not just Apache 2.2, please voice your opinions and provide detail about why this is important to you.

photo
2

Apache 2.4 is the current stable version. More people are using this or will be upgrading to this version. Apache 2.2 is the oldstable.


Why are you not supporting the new modules immediately with the current stable versions of Apache?

photo
1

Adding MPM ITK support for Apache 2.4 is a wonderful feature request. I also think it'd be a great addition to EasyApache. Our implementation of ITK support for Apache 2.2 is nearing completion and we are actively discussing adding 2.4 support.

photo
1

Hi Rachid,


When we started the ITK implementation for Apache 2.2 there was not solid support or compatibility for ITK and 2.4. That has since changed as ITK support in 2.4 has become a reality.


We are actively discussing the inclusion of ITK with Apache 2.4 and I will monitor this request as more folks request this feature.

photo
2

So we would have to downgrade Apache to use ITK?

Bringing out support for an Apache version ( 2.2) which is already outdated seems a little backward to me. I put it to you that most people are using Apache 2.4 so it might have been better to wait till you have ITK working on the latest stable version.

photo
1

kernow wrote:

So we would have to downgrade Apache to use ITK?

Bringing out support for an Apache version ( 2.2) which is already outdated seems a little backward to me. I put it to you that most people are using Apache 2.4 so it might have been better to wait till you have ITK working on the latest stable version.

Thanks for the comment, Kernow. You make a lot of valid points. Please subscribe to this feature request so you can stay up to date with its progress. As I mentioned in an earlier comment we are discussing the implementation of ITK with Apache 2.4. support.

photo
1

kernow wrote:

So we would have to downgrade Apache to use ITK?

Bringing out support for an Apache version ( 2.2) which is already outdated seems a little backward to me. I put it to you that most people are using Apache 2.4 so it might have been better to wait till you have ITK working on the latest stable version.

According to our EasyApache build data, only 15-18% of builds include Apache 2.4. Releasing first for Apache 2.2 means we get the biggest reach.

photo
1

Only 15-18% of web hosting company's using cpanel run Apache 2.4??? I am totally shocked by that, though I assume that figure is based on your clients who choose to send the data back to you? even so its unbelievably low.

photo
1

kernow wrote:

Only 15-18% of web hosting company's using cpanel run Apache 2.4??? I am totally shocked by that, though I assume that figure is based on your clients who choose to send the data back to you? even so its unbelievably low.
I agree that number is lower than we would assume, or want. Apache 2.4 offers a lot of great features. Getting people to move to Apache 2.4 is a different topic however :)

photo
1

Yes please!!

photo
1

I just want to echo the sentiments of all of the above posters.


As an aside .. cpanel really shouldn't be relying on votes/interest in this feature request forum. I've been using cpanel and doing cpanel admin work for the last 10 years and I only found about this web site very recently. I think very few people know it exists or what's actually being voted upon.

photo
2

Kenneth, although the majority may not use 2.4 yet, that is likely because we do not want to upgrade to 2.4 until MPM-ITK is available! Patch-22.

photo
3

I am just wondering why this is a feature request. Reading that only about 15-18% of cpanel users run apache 2.4 kind of shocks me, but does make it more understandable, though personally i can't think of many reasons to stick with apache 2.2 unless you're using some non-default easyapache setup?

Either way seeing how you have already got an apache 2.2 implementation and this request is now about half a year old, is there an ETA on an apache 2.4 implementation?

photo
1

Kenneth Power wrote:

According to our EasyApache build data, only 15-18% of builds include Apache 2.4. Releasing first for Apache 2.2 means we get the biggest reach.
It seems to me that if people do not want to upgrade to apache 2.4, they would also not be likely to switch MPM to MPM-ITK.

photo
2

Kenneth - I hope you apreciate how frustrating it is to have to make these choices:


mod_ruid2 - no caching and broken modsec

mod_itk - apache 2.2 and fire/brimstone warnings in the ui about how it will not be supported.


SuPHP is crazy old and slow. There no other user based / high perf options for smaller systems. You can't have a limited system full of warnings and then use that to judge user adoption.


Too bad this didn't make EA 3.3 :(


fyi (i actually see 2 options for mpm-itk in EA and the link to CP page is broken which is very confusing.)

photo
1

Hi sonicthoughts,


I understand your concerns for a solution to an MPM-ITK or mod_ruid2 equivalent in Apache 2.4. I am personally very much looking forward to greater adoption of Apache 2.4 and I believe updating our support of optional modules is an integral step in achieving this.


With Apache 2.4 being made the new default in EasyApache3, we are taking a closer look at updating EA3 profiles and related modules, including MPM ITK. I do not have an ETA at this time but it is being given increased attention. If any new status updates become available we will let you know via this feature request.


Regarding the broken link you observed, which I'm understanding may be in EasyApache, please consider filing a support request so that we can confirm and escalate this as a bug report; this will be greatly appreciated so we can ensure it is corrected. I looked for but had difficulty confirming exactly which link may be broken in EasyApache. https://go.cpanel.net/supportrequest

photo
2

of course people arent going to upgrade to 2.4 when cpanel doesnt fully support it yet.

photo
2

11.52 with EasyApache 4 is now in EDGE, and provides support for mod_mpm_itk for Apache 2.4.

photo
1

EasyApache 4 has been released to the CURRENT tier, which provides support for mod_mpm_itk for Apache 2.4

photo
1

I do not agree this is "complete" if it is only supported in EA 4! According to docs, "EasyApache 4 is in Technical Preview."

photo
1

I don't think EA3 will ever see it and EA4, while not 100% ready, does fully support it.

I'd guess no more development is needed for EA4 so completed is valid.

photo
1

I'm really outraged that this is marked complete for the following reasons:


1. EA4 is still documented as in Technical Preview and has many incompatibilities with EA3.

2. MPM-ITK has many limitations that are basic requirements:

  • Modesecurity
  • Caching (memcache/etc)
  • EAccelerator

I know there are separate requests, Don't care if EA3 or EA4 but basic need is:

memcache

modsec

mpm-itk (or mod_ruid2)

apache 2.4

PHP 5.5 and 5.6

I think this is a very common need for performance / basic security.

photo
1

According to the documentation MPM-ITK is not supported with Apache 2.4


https://documentation.cpanel.net/pages/viewpage.action?pageId=2468606#ApacheModules-ModulesthatareintheBasic,ModRuid2andMPMITKprofilesbydefault


If this is incorrect and as this post suggests it IS supported, then will it also work with request above:

memcachemodsecmpm-itk (or mod_ruid2)apache 2.4PHP 5.5 and 5.6

photo
1

Is this not completed or the documentation incorrect - PLEASE RESPOND!


MPM ITKchoice-yeschoice-noImplements a non-threaded web server that allows each VirtualHost to run under a separate UID and GID.

We introduced the MPM ITK option to servers that use Apache version 2.2 in the following versions:

  • cPanel & WHM version 11.40.1.16
  • cPanel & WHM version 11.42.1.19
  • cPanel & WHM version 11.44.0.8
  • All cPanel & WHM builds of 11.46

photo
1

HI,


EA4 is now stable, and has support for ITK and Apache 2.4. This is 100% complete. Sorry for the documentation lags, I'll work on getting those updated ASAP. Thanks for the report, and sorry for the confusions!

Replies have been locked on this page!