Only Direct Auto Responder Option

timoto shared this idea 4 years ago
Open Discussion

cPanel needs an option to force autoresponders to only respond from mails sent directly to an account instead of forwarded to an account.

Currently if contact@domain.com is forwarded to john@domain.com the autoresponder for john@domain.com is sent instead of the autoresponder setup for contact@domain.com.

This is both confusing and revealing of potentially sensitive information to the person receiving the autoresponder.

For example if a serious business query is made from smithers@rich.com to contact@domain.com and john@domain.com has a more personal autoresponder "on a madcap holiday bungee jumping off cliffs, back in a month, maybe". What is smithers@rich.com to think, he doesn't know who john@domain.com is, never sent an email to john@domain.com and doesn't/shouldn't need/want to know about the forthcoming holiday of john@domain.com.

This is not the official response that the company wants to give to smithers@rich.com

The company would prefer an option to force only direct autoresponders such that smithers@rich.com will only see an autoresponder from contact@domain.com such as "we are dealing with your request and will respond shortly"

Comments (4)

photo
4

I support this request. I'd tweak it though. Whilst I agree with the scenario outlined above, there's also the case where John users an alias address john.smith@domain.com. In this case he *does* want the auto-responder to fire for anything sent to john@ or john.smith@, but no to fire for e-mail sent to contact@.

What would be ideal is that, when setting-up forwarding in cpanel, you can specify whether this forward triggers an auto-response or not. The setting would be Yes for john.smith@, but would be No for contact@.

photo
1

That sounds wise! Thanks!

Please cPanel, do consider and implement this.

Any chance we could get it any time soon? When?

Thanks,

photo
1

Yes please.

We had a client switch to us and ran into issues because their previous host had the auto-responders implemented in that way and they rely on it.

Their general information e-mail is info@domain.com. Everything is also forwarded to owner@domain.com so she can keep an eye on things.

Now she went on a trip and put an auto-responder on her owner@domain.com and everyone e-mailing to info@domain.com got her auto-responder - from her e-mail address of course - that she is out of the office and only checks the e-mail sporadically.

Not good.

photo
2

I found a workaround for now.

Keep having public@domain forward to secret@domain.com.

For secret@domain.com set up an user-level filter:

Rules:

"Any Header" "contains" "Envelope-to: public@domain"

Action:

"Deliver to Folder" "/INBOX"

It seems that cPanel adds that additional header into the e-mail when forwarding.

Now, I don't know if "equals", "begins with" or "ends with" works as well. It was a users' account and I didn't want to play around too much with her autoresponder while she wasn't actually on vacation - especially since she was already unhappy about previous tries to working properly in the end while it worked that way on her previous host (not cPanel).

Also as a note - I tried the built in "Filter Test" and it did NOT catch it. Actual e-mails do work though.

I guess cPanel doesn't recognize "Envelope-to" as a header in the test box.