cPanel & WHM Version 94 has been released, and brings a slew of great updates. Take a look at what is included, and then upgrade today!

Update ionCube Loaders in EasyApache to v4.5.x to support PHP 5.5

tch shared this idea 6 years ago
Completed

Add IonCube for PHP 5.5 in EasyApache


Version 4.5 loader packages include

loaders for PHP 5.5. The PHP 5.5 loaders will also run PHP 5.3 and PHP

5.4 encoded files.

Best Answer
photo

After reviewing ionCube's forums, it appears that you are correct in that ionCube Loader version 4.5.x contains loaders for PHP 5.5.


Source: http://forum.ioncube.com/viewtopic.php?t=4109


"Version 4.5 loader packages are now available from our Loaders Page (http://www.ioncube.com/loaders.php) and include loaders for PHP 5.5.


As previously mentioned, the PHP 5.5 loaders will run PHP 5.3 and PHP 5.4 encoded files and are available for Unix-style platforms such as Linux, OS X and FreeBSD. Windows loaders will follow in due course." - alastair, ioncube.com forums

Accordingly, the new loaders will be reviewed for compatibility and considered for inclusion into EasyApache.

Comments (11)

photo
1

After reviewing ionCube's forums, it appears that you are correct in that ionCube Loader version 4.5.x contains loaders for PHP 5.5.


Source: http://forum.ioncube.com/viewtopic.php?t=4109


"Version 4.5 loader packages are now available from our Loaders Page (http://www.ioncube.com/loaders.php) and include loaders for PHP 5.5.


As previously mentioned, the PHP 5.5 loaders will run PHP 5.3 and PHP 5.4 encoded files and are available for Unix-style platforms such as Linux, OS X and FreeBSD. Windows loaders will follow in due course." - alastair, ioncube.com forums

Accordingly, the new loaders will be reviewed for compatibility and considered for inclusion into EasyApache.

photo
1

Good news on the loaders for IonCube. I am also in need of this update to add IonCube for PHP 5.5 in EasyApache. Hope it makes it into an EasyApache release in the very near future.

photo
2

This is taking way too long, is there a workaround for the time being?

photo
1

Please cPanel, do consider this.

Any chance we could get it any time soon? When?

Thanks,

photo
1

Any news ? Thanks.

photo
2

Hey everyone,


We are planning this update. I'll keep this feature request updated with our progress.

photo
1

Hello again!


IonCube 4.6.1 with PHP 5.5 support has been released in EasyApache 3.24.19. Please see our change log here.

photo
1

Thank you.

photo
4

Is there any possibility of ionCube being updated to at least 4.7.2 (released in November)?

This provides a useful improvement for PHP 5.5 and 5.6 support in that files encoded with older versions of the encoder can be loaded (the current version 4.6.1 of the loader will only load files encoded from 5.3 onwards).

photo
2

Current ioncube loader installed by WHM (4.6.1) is creating random heap corruptions in PHP 5.4 and PHP 5.5 when xCache is enabled.

Ioncube 4.7.3 and 4.7.4 don't have that problem.

Could you please update it asap?

photo
1

Still awaiting cpanel to inlcude latest ioncube loader.

Replies have been locked on this page!