XCache in EasyApache4

jmginer shared this idea 7 months ago
Not Planned

As a server administrator I would like cPanel to package and distribute XCache for EasyApache 4.

Best Answer
photo

Unfortunately we will not be planning to implement this request at this time. I'll leave this request on the site, but as David said, if there are applications still requiring xcache, you would need to encourage the user to switch to a modern application.

Comments (7)

photo
2

Is there a reason opcache won't work for you? Xcache hasn't been updated in almost 2 years.

photo
1

opcache not support php 5.4.

photo
1

PHP 5.4 has passed end-of-life and is no longer receiving updates, even for security issues. Please consider upgrading to a supported version of PHP.

photo
1

Hello,
How about add this option to 5.5 and 5.6 because:

Opcode caching programs are not compatible with the suPHP or CGI PHP handlers. The caching program either does not function, or functions incorrectly.

Many hosters using suPHP/CGI with MultiPHP mode, and some cacher is very need

photo
1

We have a customer with a website that not run until xcache is enabled:

"The xcache extension must be loaded for using this backend"

photo
1

What site software are they using? That error message suggests maybe a different 'backend' could be used instead of xcache.

Xcache hasn't had a release since 2014, and their website is not accessible. The project is almost certainly dead. PHP applications that require xcache need to be updated to use opcache, or users need to migrate to software that provides updates.

photo
2

Unfortunately we will not be planning to implement this request at this time. I'll leave this request on the site, but as David said, if there are applications still requiring xcache, you would need to encourage the user to switch to a modern application.